yli4ka2007
08.05.2023 01:12

Разработать алгоритм и программу. Дана матрица B размерностью nxn (2<=n<=50 – вводится пользователем). Элементы матрицы bij являются вещественными числами и принимают значения в диапазоне [0, 200]. Заполнение матрицы осуществляется в соответствии с выбором пользователя: - пользовательский ввод с клавиатуры;
- заполнение случайными числами в установленном диапазоне.
Произвести линейную сортировку элементов, стоящих на главной или побочной диагонали (по выбору пользователя).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vinchez1
13.04.2021 21:25

Задание 1: 4132

4 Экзамен | ЕГЭ | Информатика | Литература

1 Экзамен | ЕГЭ | Информатика

3 Экзамен | ЕГЭ

2 Экзамен & ЕГЭ & Информатика

Задание 2: 3124

3 рыбки

1 рыбки & аквариум

2 рыбки & аквариум & гуппи

4 рыбки & аквариум & гуппи & купить

Задание 3: 3421

3 Сок | Нектар

4 Сок

2 Сок & Апельсин

1 Сок & Апельсин & Яблоко

Задание 4: 2134

2 волейбол | баскетбол | подача | блок

1 волейбол | баскетбол | подача

3 волейбол | баскетбол

4 волейбол & баскетбол & подача

Задание 5: 2341

2 алгоритм & сжатие & графика & архиватор

3 алгоритм & сжатие

4 алгоритм | (сжатие & графика)

1 сжатие | графика | алгоритм

Задание 6: 1423

1 (Автомобили – Ford) & новые

4 Автомобили – Ford

2 Автомобили

3 Автомобили | Ford

Задание 7: 3124

3 отдых & Сочи & Адлер

1 отдых & (Сочи | Адлер)

2 отдых & (море | Сочи | Адлер)

4 отдых | Сочи | Адлер

Задание 8: 4123

4 строительный & стоимость & купить & купить

1 строительный & стоимость & купить

2 строительный | материал | купить

3 строительный | материал | стоимость | купить

Задание 9: 5000

Новосибирск 3300

Красноярск 2200

Новосибирск & Красноярск 500

Новосибирск | Красноярск 5000

Задание 10:

Атос & Портос 335

Атос & Арамис 225

Атос & Портос & Арамис 120

Атос & (Портос | Арамис) 440

Графические подтверждения:


В таблице приведены запросы к поисковому серверу. Расположите номера запросов в порядке убывания кол
В таблице приведены запросы к поисковому серверу. Расположите номера запросов в порядке убывания кол
0,0(0 оценок)
Ответ:
rkarina79
31.07.2021 08:06
Язык C++.
1. #include <iostream>
using namespace std;
int main() {
    int i;
    cout <<"Введите число: " << endl;
    cin >> i;
    cout << "Вы ввели число: " << i << endl;
    }

2. #include <iostream>
using namespace std;
int main (){
    int i;
    cout << "Vvod" << endl;
    cin >> i;
    i %= 10;
    if(i %2 != 0)
    cout << "Нечетная" << endl;
    else
    cout << "Четная" << endl;
    }

3. #include<iostream>
using namespace std;
int main (){
for(int k = 0; k<4; k++){
cout << "random number = " << rand() << endl;
}
}

4. #include <iostream>
using namespace std;
int main(){
int i,a,b,c;
cin >> i;
c = i%10;
b =(i/10)%10;
a = i/100;
if(i*i==a*a*a+b*b*b+c*c*c)
cout<<"Является."<<endl;
else 
cout<<"Не является."<<endl;
}

5. #include <iostream>
#include <cmath>
const double pi = 3.1415926536;
using namespace std;
int main(){
    float x = 0;    cout << "Введите x: " << endl;
    cin >> x;
    cout << "y = " <<  sin((pi*(3.2+(sqrt(1+x))))/180)/abs(5*x) << endl;
    }

Добавляем "pi" и делим на 180, чтобы "sin" был в градусах.

Блок-схемы смотри во вложении.
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота