ali0002
23.09.2021 08:48

Напишите программу, которая по введенному целому числу а (0≤ а ≤ 999999) находит сумму цифр этого числа s.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vikavikt
23.06.2020 17:54
Var a,col:integer;
s:string;
begin
readln(a);
if (a<0) OR (a>999999) then
writeln('Число А не соответствует условию')
else
begin
s:=IntToStr(a);//Переводим из числовой в строковую величину
col:=length(s);
writeln('Количество: ',col);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота