Тембулат14
12.12.2021 15:16

В Среде Delphi составьте программу,которая чертит 4 разные концентрические окружности ​


В Среде Delphi составьте программу,которая чертит 4 разные концентрические окружности ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
strong28
13.10.2020 02:38
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
const
  КолСтрок=3;
  КолСтолбцов=5;
begin
  var Массив: array [1..КолСтрок,1..КолСтолбцов] of integer;
  var СуммыПоСтрокам: array[1..КолСтолбцов] of integer;
  Writeln('Введите элементы массива (',КолСтрок,',',
    КолСтолбцов,') построчно:');
  for var строка:=1 to КолСтрок do
    for var столбец:=1 to КолСтолбцов do begin
      Read(Массив[строка,столбец]);
      СуммыПоСтрокам[строка]+=Массив[строка,столбец]
      end;
  Writeln('Суммы построчно:');
  for var строка:=1 to КолСтрок do Print(СуммыПоСтрокам[строка])
end.

Тестовое решение
Введите элементы массива (3,5) построчно:
7 -5 13 19 -11
8 23 -15 -6 0
12 -6 -9 0 12
Суммы построчно:
23 10 9
0,0(0 оценок)
Ответ:
ЛизаПру
15.04.2020 13:48
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходный массив'); a.Println;
  var se:=a.Where(x->x mod 3=0);
  if se.Count=0 then
    Writeln('В массиве нет элементов, кратных трем')
  else begin
    var b:=se.Max;
    var i:=0;
    while a[i]<>b do Inc(i);
    if i=n-1 then Writeln('Максимальный элемент - последний')
    else begin
      Writeln('Результирующий массив');
      a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println
      end
    end
end.

Тестовое решение:
n= 15
Исходный массив
-24 -38 15 -33 -40 -18 21 34 20 49 -19 29 29 38 -41
Результирующий массив
-24 -38 15 -33 -40 -18 21 213 20 49 -19 29 29 38 -41
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота