GAMAEW66
03.09.2020 06:28

1. Написать программу для проведения операций над матрицами (сложение, умножение на число, умножение матриц, транспонирование, возведение матрицы в степень). 2. Ввод матрицы можно осуществлять как с клавиатуры, так и случайные числа (выбирается пользователем)
3. Размерность матрицы вводится пользователем в начале
4. Выбор операции также производится пользователем
5. Каждая строка кода должна быть прокомментирована (коротко) #comment
6. Вывод должен быть форматированным и аккуратно оформлен
7. Программы должны быть у всех разные.
8. Проверка всех возможных исключений (ввод букв вместо цифр, неверные размерности матриц и т.д.)

Этапы программы:

выбор операции (выбирает пользователь)

ввод размерности (строка приглашения)

выбор генерации матрицы (случайными числами или пользователем)

заполнение

вывод результата операции (в аккуратном виде)
Без использования любых библиотек

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladgubin78
10.06.2021 15:32
Информационный объем текста с учетом избыточности составит
100 Кб × (1+25/100) = 125 Кб
Переведем этот объем в килобиты.
1 Кб = 1024 б = 1024×8 бит = 8192 бита;
125 Кб = 125 × 8192 = 1 024 000 бит
Определим время передачи.
За 1 с передается 10 кбит, т.е. 10 000 бит.
Тогда время передачи составит 1 024 000 / 10 000 = 102.4 с

Так задача должна решаться, если использованы единицы измерения информации по ГОСТ (1 Кбайт = 1024 байта, 1 кбит = 1000 бит). Обратите внимание, что у Кбайт буква "К" заглавная, что указывает на её внесистемность относительно системы СИ. Исторически пропускная каналов передачи данных измеряется в битах/с, причем с использованием системных приставок единиц измерения (к - кило, 10³, м - мега, 10⁶ и .т.д.).

Но тут в условии почему-то использована заглавная буква "К" и при указании скорости передачи, а по ГОСТ это означает множитель 2¹⁰ = 1024.
Если придраться к этой записи, то мы имеем право написать, что 10 Кбит/с это 10 240 бит/с, а не 10 000 бит/с и в ответе получим ровно 100с.

Выбор за автором вопроса.
0,0(0 оценок)
Ответ:
muxametzhanovad
16.06.2021 23:47
#include "stdafx.h"
#include "conio.h"
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "Russian");
cout << "Добро в магазин книг!" << endl;
cout << "Выберите книгу из предложенного списка." << endl;
cout << "Список:" << endl << "1. Книга 1. " << "Стоимость 590 рублей" << endl; cout << "2. Книга 2. " << "Стоимость 440 рублей" << endl << "3. Книга 3. " << "Стоимость 330 рублей" << endl;
int a, b, k, d;
cout << endl;
cin >> d;
if (d <= 3)
{
  switch (d)
  {
 case (1):
 {
  k = 590;
  break;
 }
 case (2):
 {
   k = 440;
  break;
 }
case (3):
 {
  k = 330;
  break;
 }
 }
 cout << "Внесите платеж!" << endl;
  cin >> a;
 if (a > k)
 {
  b = a - k;
  cout << "Возьмите сдачу " << b << " рублей.";
  }
 else if (a < k)
 {
  b = k - a;
  cout << "Внесенной вами суммы недостаточно для покупки товара!" << endl; cout << "Доплатите " << b << " рублей" << endl;
  }
 else if (a = k)
  cout << " за покупку!" << endl;
 }
else
 {
 cout << "Выбери книгу из предложенного списка!" << endl;
 }
_getch();
return 0;
}
Cоставьте программу на языкe с++ реализовать эпизод применения компьютера в книжном магазине: компью
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота