Boxing12474
11.03.2022 09:09

САМОЕ ГЛАВНОЕ! Через цикл While! Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0. В последовательности всегда имеется число, оканчивающееся на 6. Введённые числа не превышают 30 000. Программа должна вывести одно число —минимальное число, оканчивающееся на 6.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alinkaaa25
29.06.2021 12:00

c++

#include <iostream>

using namespace std;

int main()

{

   int x = 1, min = 99999;

   while(x){

       cin >> x;

       if(x % 10 == 6 && x < min) min = x;

   }

   cout << min;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота