shah25
25.10.2020 15:03

Напишите программу на КуМире. "Робот-контроллер"
На бесконечном поле имеется терминал, возведенный вокруг ядерного реактора. Длины стен терминала неизвестны. Для контроля уровня радиации используется Робот. В его задачу входит периодический обход периметра терминала. Клетки, в которых уровень радиации больше критического (критическим является уровень радиации равный 30), Робот должен пометить (закрасить).
Также после окончания обхода Робот должен сформировать отчет о среднем уровне радиации по периметру терминала.
Напишите программу для работы Робота.
Робот находится в левой верхней клетке, как показано на рисунке (см. рис.1).


Напишите программу на КуМире. Робот-контроллер На бесконечном поле имеется терминал, возведенный в

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alenagalcheva
10.03.2022 10:53

ответ:Внутри условных инструкций можно использовать любые инструкции языка Питон, в том числе и условную инструкцию. Получаем вложенное ветвление – после одной развилки в ходе исполнения программы появляется другая развилка. При этом вложенные блоки имеют больший размер отступа (например, 8 пробелов). Покажем это на примере программы, которая по данным ненулевым числам x и y определяет, в какой из четвертей координатной плоскости находится точка (x,y):

x = int(input())

y = int(input())

if x > 0:

   if y > 0:               # x>0, y>0

       print("Первая четверть")

   else:                   # x>0, y<0

       print("Четвертая четверть")

else:

   if y > 0:               # x<0, y>0

       print("Вторая четверть")

   else:                   # x<0, y<0

       print("Третья четверть")

В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

Объяснение:В этом примере мы использовали комментарии – текст, который интерпретатор игнорирует. Комментариями в Питоне является символ # и весь текст после этого символа до конца строки.

0,0(0 оценок)
Ответ:
valu49
05.05.2022 12:08
1.
Begin
 Writeln('Привет!');
 Writeln('Меня зовут Саша!');
 Writeln('Я студентка 2-ого курса начального образования!');
 Writeln('Я будущий учитель младших классов...');
end.

2.
var n:Integer;
Begin
 Read(n);
 Writeln('Квадрат =',n*n);
end.

3.
var a:Integer;
Begin
 Read(a);
 Writeln('S = ',a*a);
 Writeln('P = ',4*a);
end.

4. var n:Integer;
   Begin
     Read(n);
     Writeln(n+10);
  end.

5. var a,b:Integer;
   Begin
     Read(a,b);
     Writeln(' S = ',a*b);
     Writeln(' P = ',2*(a+b));
   end.

6. var a,b,c:Integer;
   Begin
     Read(a,b,c);
     Writeln('Сума = ',a+b+c);
   end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота