кукушка137
18.05.2021 02:49

Вмассиве из 20 целых чисел найдите наибольший элемент среди отрицательных и поменяйте его местами с первым элементом. вот начал делать, а потом не знаю как дальше: const k=20; var a: array[1..k] of integer; g,i,max: =integer; begin for i: =1 to n do begin a[i]: =random(20)-10; write(a[i],' '); max: =a[i]; for i: =1 to n do if a[i]< 0 then max: =a[i]; writeln('max=',max); end; дальше не знаю, там по-моему надо ввести переменную (в моём случае "g") и мне кажется там ошибка в поиске максимально среди отрицательных элементов. .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
weri8
23.06.2020 16:48
Var 
a:array[1..20] of integer;
i,max,c,nom:integer;
begin
max:=-100000000;
for i:=1 to 20 do begin
a[i]:=random(20)-10;
write(a[i],' ');
end;
for i:=1 to 20 do begin
if (a[i]<0) and  (a[i]>max) then  nom:=i;
if (a[i]<0) and  (a[i]>max) then max:=a[i];
end;
writeln;
for i:=1 to 20 do begin
if i=nom then swap(a[nom],a[1]);
end;
for i:=1 to 20 do begin
write(a[i],' ');
end;
writeln('max=',max,');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота