mazurenkoella
20.12.2022 10:03

Надо ! 1.составьте программу двух обыкновенных дробей (с клавиатуры должны вводиться их числители и знаменатели ). 2.составьте программу, позволяющую выяснить, есть ли у n два простых делителя. 3.составьте программу, отыскивающую наименьший общий составной делитель натуральных чисел n и m. 4. составте программу, вычесления суммы четырехзначных чисел, в десятичной записи которых есть два нуля.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ssnz344
23.06.2020 16:13
Вот первая
var
  a1, a2, a3, b1, b2, b3, n : integer;
function NOD (a, b : integer) : integer;
begin
  if b = 0 then NOD := a
  else NOD := NOD (b, a mod b);
end;
begin
  write ('Введите первую дробь : '); read (a1, b1);
  write ('Введите вторую дробь : '); read (a2, b2);
  a3 := a1 * a2;
  b3 := b1 * b2;
  n := NOD (a3, b3);
  a3 := a3 div n;
  b3 := b3 div n;
  write (a3, '/', b3);
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота