Veravera002003004049
02.04.2022 15:29

По программированию на с++ с использованием оператора while () написать программу, которая будет выводить на экран: «введи многозначное число», затем считывать введенное с клавиатуры целое число, считать количество цифр и выводить на экран корректную фразу: «в числе ! число! ! результат! цифра/цифры/цифр»

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
умар53
01.10.2020 12:06

Объяснение:

#include "pch.h"

#include <stdio.h>

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int num, k=0;

string str;

cout << "Введи многозначное число" << endl;

cin >> num;

while (num != 0)

{

 k += 1;

 num /= 10;

}

if(k==1)

{

 cout << k << " цифра" << endl;

}

else if (k >= 2 && k <= 4) {

 cout << k << " цифры" << endl;

}

else {

 cout << k << " цифр" << endl;

}

system("pause");

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота