tigersarecool
18.03.2021 15:49

Написать программу в pascalabc.net задано натуральное число .напишите программу ,которая для число с нечётным количеством цифр выведет на экран цифру , стоящую на средней позиции числа .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
NoNameKek1Himka
07.06.2020 00:05

var

 x, a, k, t, i, d: integer;

begin

 readln(x);

 a := x; k := 0;

 while a > 0 do

 begin

   k += 1;

   a := a div 10;

 end;

 if k mod 2 = 0 then

   write('В числе четное количество цифр')

 else

 begin

   t := 1;

   for i:=1 to k div 2 do

     t *= 10;

   d := x div t mod 10;

   write(d);

 end

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота