Darkness171
20.11.2022 03:47

Напишите программу, которая будет выводить на экран элементы последовательности трибоначчи- первые элементы последовательности: 0,0,1,1,2,4,7,13,24,44 81,149.. каждый элемент, начиная с четвертого, равен сумме трех предыдущих: an= an-1 + an-2 + an-3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
CoRoLi07
19.11.2020 20:13
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

3. Заполнить массив случайными целыми числами (0-10). Найти сумму четных и нечетных значений.

begin
  var a:=ArrRandom(ReadInteger('n='),0,10); a.Println;
  var so:=a.Where(t->t.IsOdd).Sum;
  var se:=a.Where(t->t.IsEven).Sum;
  Writeln('Сумма четных значений равна ',so,', нечетных ',se)
end.

Пример
n= 15
4 2 1 9 1 1 6 5 10 8 3 9 7 7 9
Сумма четных значений равна 52, нечетных 30

5. Заполнить массив целыми числами с клавиатуры. Найти произведение всех элементов массива.

Ограничим ввод нулем, поскольку ввод нуля обнулит все произведение.

begin
  ReadSeqIntegerWhile(t->t<>0).Aggregate(BigInteger(1),(p,q)->p*q).Println
end.

Пример
-4523 235423 6734532 2342354 67345423 2342342 -43532423 0
115347094687898985235964440890392383424914416

7. Заполнить массив случайными целыми числами в интервале от 0 до 18. Найти наибольший элемент среди всех чисел массива и указать его номер.

begin
  var a:=ArrRandom(ReadInteger('n='),0,18); a.Println;
  var imax:=a.IndexMax;
  Writeln('Наибольший элемент ',a[imax],' имеет номер ',imax+1)
end.

Пример
n= 13
1 4 8 18 14 14 7 1 12 15 16 12 11
Наибольший элемент 18 имеет номер 4
0,0(0 оценок)
Ответ:
sssqwdsgdsgds
09.07.2022 18:04

1.Создайте макрос с именем (к примеру) "Моё меню"

2.В этом макросе добавляем пункты меню следущим образом: Для каждого пункта меню, создаём "Вложенный макрос". Название каждого вложенного макроса - будет названием пункта меню.

3.В каждом вложенном макросе должна быть хотя бы одна команда. Хотя бы просто "Примечание". Иначе, он в списке не появится.

4.Чтобы вставить разделитель, называем нужный вложенный макрос именем "-" (минус) и добавляем примечание

5.Чтобы сделать быструю кнопку к пункту меню, перед нужной буквой в названии макроса вставляем "&"

6.Ну и естественно, в каждом вложенном макросе реалиуем необходимый функционал либо через макрокоманды, либо через "ЗапускПрограммы"

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота