СерегаБатя
24.01.2021 23:56

70 . дан целочисленный массив из 30 элементов заданный случайным образом. элементы массива могут принимать целые значения от -30 до +30 - значение среднесуточной температуры для каждого из 30 дней некоторого месяца. составьте программу, которая позволяет найти и вывести количество дней этого месяца, температура для которых была выше, чем температура в предыдущий день этого же месяца. паскаль. (там var, array, integer или тип того)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
EgrVir2018
24.05.2020 19:30

const n=30;

var a:array[1..n] of integer;

i,k:integer;

begin

randomize;

writeln('Исходный массив:');

for i:=1 to n do

begin

a[i]:=random(61)-30;

write(a[i],' ');

end;

writeln;

k:=0;

for i:=2 to n do

if a[i] > a[i-1] then k:=k+1;

writeln('k = ',k);

end.

Пример:

Исходный массив:

27 -16 19 23 12 3 25 6 -3 -22 12 13 22 -8 -3 7 -1 -20 -28 -20 25 22 13 -8 -3 -17 14 22 11 -9  

k = 13

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота