KittiKitimi
12.01.2023 10:08

Составить программу для вычисления значения функции f(x)=x*cos(1/x)+2 на отрезке [a,b] с шагом h. результаты представить в виде таблицы (1-ый столбец - значения аргумента, 2- ой -значение функции).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Misha01923
22.06.2020 17:19
Const
  n = 10;
 
var
  a,b,h,x: real;

begin
  writeln('a , b , h =');
  read(a, b, h);
  x := a - h;
  writeln('x':n, ' | ', 'y':n);
  repeat
    x := x + h;
    writeln(x:n:3, ' | ', (x * cos(1 / x) + 2):n:3);
   
  until x >= b;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота