Denchik01TURBO
14.09.2020 03:36

Паскаль) ) напишите программу вычисления среднего модулей двух введенных с клавиатуры чисел. программа должна использовать цикл while do. условия выхода их цикла-значение числа, равное 999.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yuakomlev
22.06.2020 16:29
Var a,b,sg: real;
begin
readln(a);
readln(b);

a:=abs(a); b:= abs(b);
sg:= sqrt(a*b);

writeln(sg);
end.

Вот программа вычисления средней геометрической. Но про цикл не понял...
0,0(0 оценок)
Ответ:
lkivaka
22.06.2020 16:29
Program Zadacha;
Var a, b, i: Integer;
c: Real;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
c := Sqrt(Abs(a) * Abs(b));
i := 0;
While i < 999 Do
i := i + 1;
WriteLn('Результат: ', c:5:2);
ReadLn;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота