bigman4
26.05.2022 18:54

Дан массив из 30-ти элементов. каждый элемент может принимать целочисленные значения от -100 до 100. напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. qbasic

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Пам904
22.06.2020 15:00
Искренне надеюсь, что Вы сможете перевести этот код к нужному виду..:) В принципе, расхождения должны быть только в вводе/выводе (где Console.Бла-бла-бла) и генерации случайных чисел)

Sub Main()
        Dim a(29), Sum, Col As Integer
        Dim Rnd = New Random()
        For i As Integer = 0 To 29
            a(i) = Rnd.Next(-100, 100)
            Console.Write("{0} => {1}" + Environment.NewLine, i, a(i))
            If (i > 0) Then
                If (a(i) Mod a(0)) Then
                    Sum = Sum + a(i)
                    Col = Col + 1
                End If
            End If
        Next
        Console.WriteLine(Math.Round(Sum / Col, 2))
        Console.ReadKey()
    End Sub
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота