ИЛЬЯ2161
16.06.2020 07:15

Написать программу на visual basic заполнить массив из 10 строк и 10 столбцов случайными двузначными натуральными числами. вывести его на экран. вывести номера элементов, которые являются локальными максимумами (больше всех своих соседей). уровень а (70 ): считаем соседними четыре элемента:
сверху, снизу, слева, справа); крайние элементы, у которых соседей меньше, чем 4, максимумами быт не могут. уровень в (80 ): то же, что в а, но учитываем и соседей по диагонали. уровень с (100 ): то же, что в а, но крайние элементы тоже рассматриваем - они считаются максимумами, если больше всех
имеющихся соседей. заранее !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vikaraduga
15.04.2021 23:44
мне лень на паскале + он туповат, вот код на С++ (современный язык на ряду с Java)

#include <bits/stdc++.h>
#include <conio.h>
typedef long long   lol;
typedef unsigned long long ull;
typedef int         it;
typedef bool        bl;
typedef long double ld;
typedef char        cr;
#define mp          make_pair
#define INF         INT_MAX
#define LINF        LONG_LONG_MAX
#define fr(i,n)     for(i=0;i<(n);i++)
#define frr(i,n)    for(i=0;i<=(n);i++)
#define wl(i,n)     while(i<n)
#define prllprll    pair < pair<long long,long long>,pair<long long,long long> >
#define prll        pair<long long,long long>
#define pri         pair<int, int>
#define F           first
#define S           second
#define sqr(a)      ((a)*(a))
#define pb          push_back
#define vll         vector<long long>
#define vit         vector<int>
#define sg          string
#define qit         queue<int>
#define qll         queue<long long>
#define pqll        priority_queue<long long>
#define pqit        priority_queue<int>
#define y           dsadaf
#define y1          lfkfgi
using namespace std;
lol a,b;
int main()
{
    cin >> a >> b;
    if (a>=1 && a<=3)
        cout << 600*b;
    else
    if (a>=4 && a<=7)
        cout << 700*b;
    else
    if (a>=8 && a<=14)
        cout << 500*b;
    else    return 0;
}
0,0(0 оценок)
Ответ:
raisabarsegyan
30.03.2022 18:51
// PascalABC.Net

function IsNice(n:longint):boolean;
// Отвечает на вопрос, является ли число красивым
var
  d,nd,sd:byte;
begin
  sd:=0; nd:=0;
  repeat
    d:=n mod 10;
    sd:=sd+d; Inc(nd);
    n:=n div 10
  until n=0;
  IsNice:=(sd mod nd = 0)
end;

var
  i,n,k:longint;
begin
  Write('Порядковый номер "красивого" числа: '); Read(n);
  i:=1; k:=0;
  repeat
    if IsNice(i) then Inc(k);
    if k<>n then Inc(i)
  until k=n;
  Writeln('Красивое число равно ',i)
end.

Тестовое решение:
Порядковый номер "красивого" числа: 15
Красивое число равно 20
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота