ЯрославР1
01.01.2020 03:00

Напишите программу которая вводит натуральное число n и находит все совершенные числа в диапазоне от 1 до n pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Zeus41
21.06.2020 07:23
Var  i, j, n, p: integer;

begin 
readln(n); 
for i := 1 to n do 
begin   
p := 0;   
for j := i - 1 downto 1 do     
if (i mod j = 0) then p := p + j;   
if p = i then writeln(i, '- совершенное число'); 
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота