паксуха
04.10.2021 17:11

Написать программу поиска сотрудника с указанным именем в массиве структур.
С++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Rezars19
10.08.2021 22:39
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Ответ:
kmatachp01gzm
24.01.2020 23:45

1.

#include <iostream>

#include <algorithm>

#include <iomanip>

#include <cmath>

using namespace std;

int main()

{

   long long b[31], i;

   for(i = 0; i < 30; i++)

   {

       b[i] = rand();

       cout << b[i] << " ";

   }

   for(i = 0; i < 30; i++)

       if(b[i] > 0)

       cout << i << " " << b[i] << endl;

   return 0;

}

2.

#include <iostream>

#include <algorithm>

#include <iomanip>

#include <cmath>

using namespace std;

int main()

{

   long long b[5][5], i, j, sum = 1;

   for(i = 0; i < 5; i++)

       for(j = 0; j < 5; j++)

       {

           cin >> b[i][j];

           if(i == j)

               sum *= b[i][i];

       }

   for(i = 0; i < 5; i++)

       {

       for(j = 0; j < 5; j++)

           cout << b[i][j] << " ";

           cout << endl;

       }

       cout << sum << endl;;

   return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота