arinaaverichev
24.03.2021 23:48

Восстановите последовательность программы, возводящей число в квадрат. В ответ запишите последовательность цифр без пробелов и каких-
либо знаков:
​


Восстановите последовательность программы, возводящей число в квадрат. В ответ запишите последовател

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
likagluxova
08.12.2020 16:01

#include <cstdlib>
#include <iostream>

using namespace std;                        //ни чего особо не значит, чисто                                                                   //синтаксис,на алгоритм не влияет

int main()                      
{

 int n=0;

 int a=1;

 while(n<=100)

 {

  if(n%3==0 && n!=0)

  {

   a*=n;                                       //a=a*n

  }

  n++;                                         //n=n+1

 }

 cout<<"Произведение равно "<<a<<endl;
 system("PAUSE");
 return 0;
}

 

 

 

 

 

(Код написан на С++.)

 

 

#include <cstdlib>
#include <iostream>

using namespace std;

int main()
{

 int n=0;

 int a=1;

 while(n<=100)

 {

  if(n!=0)                                         //если умножить на 0 то а в итоге будет равно

   a*=n;                                           //0 (0 делиться на 3)

  n+=3;                                           //n=n+3   (каждое третье делиться на 3,                                                         //увеличиваем сразу на 3)

 }

 cout<<"Произведение равно "<<a<<endl;
 system("PAUSE");
 return 0;
}

 

 

 

 

 

(Код написан на С++.)

 

 

0,0(0 оценок)
Ответ:
superviazovich
15.12.2022 07:10

#include <cstdlib>
#include <iostream>

 

using namespace std;

 

int NOD( int a, int b)
{
   int c=1;

   int d;

   if(a>b)

    d=b;

   else

    d=a;
   for(int j=1;j<=d;j++)
   {
    if(a%j==0 && b%j==0)
    c=j;       
   }
   return c;     
}

 

int main()

{

 int A,B,C;

 cout<<"Введите А"<<endl;

 cin>>A;

 cout<<"Введите В"<<endl;

 cin>>B;

 cout<<"Введите С"<<endl;

 cin>>C;

 cout<<"НОД("<<A<<","<<B<<","<<C<<")="<<NOD(NOD(A,B),C)<<endl;

 system("PAUSE");

 return 0;

}

 

 

 

 

(Код написан на С++.)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота