albinanizaeva
05.04.2022 21:17

Написать программу паскаль -перенести первое число в конец число трехзначное : )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ashotik007
20.06.2020 19:52
var a, b, c, d: integer;
begin
     readln(d);
     a := d div 100;
     b := d mod 100 div 10;
     c := d mod 10;
     writeln(b, c, a);
end.

можно ещё сократить:
var a, b, c, d: integer;
begin
     readln(d);
     writeln(d mod 100 div 10, d mod 10, d div 100);
end.

или даже:
var a, b, c, d: integer;
begin
     readln(d);
     a := d div 100;
     writeln(d - a * 100, a);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота