MariaUralova
21.06.2022 20:54

Написать программу С++ Дан массив A [25]. Создайте программу для поиска наибольшего числа элементов в индексах с нечетными номерами.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
FedorAche
31.01.2022 21:09
А)
var    s:string;    mas:array ['a'..'z'] of longint;{индексы элементов соответствуют латинице}    c:char;    i:longint; begin      read(s);      for c:='a' to 'z' do{заполнение нулями элементов массива, для запоминания количества элементов в латинице}          mas[c]:=0;      for i:=1 to ord(s[0]) do{пробегаем по всей строке ord(s[0]) это количесвто элементов в строке (только паскаль)}          mas[s[i]]:=mas[s[i]]+1;      for c:='a' to 'z' do{пробегаем по массиву значений и выводим только неповторяющиеся}          if(mas[c]=1) then                       writeln(c); end.
0,0(0 оценок)
Ответ:
ruslanchik1999
30.10.2021 16:22
Количество всевозможных программ 2^4 = 16
Перечислим их:
1111 =>  4+4+4+4 = 16
1112 =>  4+4+4-3 = 9
1121 =>  4+4-3+4 = 9
1122 =>  4+4-3-3 = 2
1211 =>  4-3+4+4 = 9
1212 =>  4-3+4-3 = 2
1221 =>  4-3-3+4 = 2
1222 =>  4-3-3-3 = -5
2111 => -3+4+4+4 = 9
2112 => -3+4+4-3 = 2
2121 => -3+4-3+4 = 2
2122 => -3+4-3-3 = -5
2211 => -3-3+4+4 = 2
2212 => -3-3+4-3 = -5
2221 => -3-3-3+4 = -5
2222 => -3-3-3-3 = -12

Перечислим полученные результаты с разными числами(одинаковые выводить не будем)
16
9
2
-5
-12

ответ: Таких чисел будет 5(пять)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота