pandokokos22jopar
10.09.2021 04:32

С клавиатуры вводится число от 1 до 1000 , 0 конец программы . Найти сумму чисел которая кратна 6 и оканчивается на 2. Написать программу в C++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
udovika
21.05.2021 14:50

.

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   long sum = 0;

   int a;

   cout << "Введите a" << endl;

   cin >> a;

   if (a > 500)

   {

       cout << "а > 500" << endl;

   }

   else

   {

       sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;

       cout << sum;

   }

}

2.

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   double average = (1 + 1000) / 2.;

   cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;

}

3

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   int a = 0, b = 0;

   cout << "Введите границы диапазона" << endl;

   cin >> a >> b;

   cout << "Все числа:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           cout << i << endl;

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           cout << i << endl;

       }

   }

   cout << "Чётные числа:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           if (i % 2 == 0)

           {

               cout << i << endl;

           }

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           if (i % 2 == 0)

           {

               cout << i << endl;

           }

       }

   }

   cout << "Нечётные числа:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           if (i % 2 != 0)

           {

               cout << i << endl;

           }

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           if (i % 2 != 0)

           {

               cout << i << endl;

           }

       }

   }

   cout << "Числа, кратные 7:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           if (i % 7 == 0)

           {

               cout << i << endl;

           }

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           if (i % 7 == 0)

           {

               cout << i << endl;

           }

       }

   }

}

4.

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   int a = 0, sum = 0;

   cout << "Введите числа" << endl;

   while (true)

   {

       cin >> a;

       if (a == 0)

       {

           break;

       }

       sum += a;

   }

   cout << "Сумма =" << sum << endl;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота