КоТоФеЙкА03
12.11.2021 12:54

1.составьте программу заполнения массива не используя клавиатуру числами -2, 4,-6,8,-. 2.сформировать одномерный массив из 30 элементов ( гсч-рандомно) из интервала -3..3. массив вывести.найти номер положительных элементов и их сумму чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DigroTube
20.06.2020 17:55
Буду считать, что да, он самый востребованный тут =)
1)
var a: array [0..9] of integer;
    i, o: integer;
begin
     for i := 1 to 20 do
     begin
          if (i mod 4 = 0) then a[o] := i
          else if (i mod 4 = 2) then a[o] := -1 * i;
          if (i mod 4 mod 2 = 0) then o := o + 1;
     end;
          for i := 0 to 9 do
         writeln(a[i]);
end.

2)
var a: array [0..30] of integer;
    i, o: integer;
    s: string;
begin
     for i := 1 to 30 do
     begin
          a[i] := random(6) - 3;
     end;
     writeln('Массив:');
     for i := 0 to 30 do
     begin
         writeln('[', i, '] => ', a[i]);
         if (a[i] > 0) then
         begin
              o := o + a[i];
              s := s + inttostr(i) + ' ';
         end;
     end;
     writeln('Номера положительных чисел: ', s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота