pankovakseniya
03.08.2022 20:35

Написать программу для обработки двумерного массива размерностью 5*5. Для каждой строки двумерного массива Q определить номера столбцов, которые содержат отрицательные элементы. Входные данные для элементов матрицы задайте самостоятельно.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alleksus
19.06.2021 03:39

подключив предварительно библиотеку <vector>

int x[5][5];

for(int i = 0; i < 5; i++){

  for(int j = 0; i<5; j++){

     x[i][j] = rand()%20 - 10;

   }

}

vec<int> vec;

for(int i = 0; i < 5; i++){

  for(int j =0; j < 5; j++){

     if(x[i][j] < 0){

        for(int f = 0; f < vec.size(); f++){

           if(vec(f) == x[i][j]) break;

           }

           else { vec.push_back(j); }

         }

      }

   }      

}

if(vec == 0) cout << "Нет столбцов с отрицательным значением";

else{ for(int j = 0, j<vec.size(); j++){

cout << vec(j) << ' ';

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота