botovaov
11.04.2022 21:40

Решить задачу на питоне Написать Класс «Канцелярия». В нем задать атрибут название и отрисовка. Создать метод который выводит на экран сообщение о начале отрисовки. Создать 3 класса-потомка: Карандаш, фломастер и ручка. Переопределить метод отрисовки так, чтобы для разных классов выводилось разное сообщение (Карандаш чертит, фломастер закрашивает и тд.)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Spanny99
06.08.2021 17:53

pascal

Объяснение:

Задание 1

var

 i, j, mini, minj: integer;

 min: real;

 a: array [1..6, 1..8] of real;

begin

 min := 30;

 for i := 1 to 6 do begin

   for j := 1 to 8 do begin

     a[i, j] := random(51) - 20;

     Write(a[i,j]:6);

     if a[i, j] <= min then begin

       min := a[i, j];

       mini := i;

       minj := j;

     end;

   end;

   WriteLn;

 end;

WriteLn('Минимальный элемент A[',mini,',',minj,']=', min);

end.

Задание 2

var

 i, j: integer;

 min: real;

 a: array [1..6, 1..8] of real;

begin

 min := 30;

 for i := 1 to 6 do begin

   for j := 1 to 8 do begin

     a[i, j] := random(11) + 20;

     Write(a[i,j]:6);

     if a[i, j] <= min then min := a[i, j];

   end;

   WriteLn;

 end;

 

 for i := 1 to 6 do

   for j := 1 to 8 do

     a[i, j] := a[i, j] - min;

 WriteLn('Новый массив:');

 for i := 1 to 6 do begin

   for j := 1 to 8 do begin

     Write(a[i,j]:6);

   end;

   WriteLn;

 end;

end.

0,0(0 оценок)
Ответ:
raddycat
06.08.2021 17:53

1. Индексом элемента называется…

- Номер элемента в массиве

  2. Массив данных имеет: - Общее имя и один тип.

 

3. Что такое массив?

- Совокупность однотипных данных, хранящихся в последовательных ячейках памяти.

 

4. В записи D[4]=3.5, D обозначает…

- Имя массива.

 

5. Какой ряд данных можно назвать массивом?

- 2.3, 5.7, 10.89.

  6. Найдите правильное описание массива.

- D: array[1..5] of real;

 

7. Для заполнения массива случайными числами мы должны подключить датчик случайных чисел, используя команду…

- Randomize;

 

8. Для заполнения массива путем ввода чисел с клавиатуры мы используем оператор…

- Readln;  

9. Что выполняет следующий фрагмент программы: For i:=1 to N do write (a[ i ], ‘ ’);

- Выводит N значений массива на экран.

 

10. Для подсчета суммы элементов массива в цикле используем следующую запись…

- Sum:=sum+a(i);

 

11. Что выполняет следующий фрагмент программы?

 Min:=a[1]; For i:=1 to N do if a[i]< min then min:=a[i]; Writeln(min);

- Выбирает минимальный элемент массива.

 

12. Для подсчета количества положительных элементов массива будем использовать условие…

- If a[i]>0 then k=:k+1;


13. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение суммы после выполнения следующего фрагмента программы:

sum:=0; for i:=1 to 8 do sum:=sum+r[i]; writeln (sum);

- 25

 

14. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение суммы после выполнения следующего фрагмента программы:

 sum:=0; for i:=1 to 7 do if r[i]>5 sum:=sum+r[i]; writeln (sum);

- 21.

 

15. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]= 4, R[6]=9, R[7]=0, R[8]=8. Определите значение переменной i после выполнения следующего фрагмента программы:

sum:=0; for i:=2 to 7 do if r[i]>5 sum:=sum+r[i]; writeln (sum);

- 9

 

16. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной i после выполнения следующего фрагмента программы: sum:=0; for i:=1 to N do if r[i]>5 sum:=sum+r[i]; writeln (sum);

- нельзя определить.

 

17. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной kol после выполнения следующего фрагмента программы: kol:=0; for i:=1 to 8 do if r[i]>-2 then kol:=kol+1; writeln (kol);

- 6.

 

18. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной kol после выполнения следующего фрагмента программы alphaeus: kol:=0; for i:=1 to 8 do if r[i]<0 then kol:=kol+1; writeln (kol);

- 2

 

19. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]= 4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной max после выполнения следующего фрагмента программы: max:=r[1]; for i:=1 to 8 do if r[i]>max then max:=r[i]; writeln (max);

- 12.

 

20. Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.

Определите значение переменной min после выполнения следующего фрагмента программы: min:=r[1]; for i:=1 to 8 do if r[i]< min then min:=r[1]; writeln (min);

- -6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота