hhhnnnvvv
27.12.2021 08:12

С++ ан массив из n элементов. Необходимо найти количество элементов массива, значения которых неотрицательны и меньше заданного числа A.

Формат входных данных
С клавиатуры вводится натуральное число n (n≤100). На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится единственное число A (0≤A≤100).

Формат выходных данных
В качестве ответа выведите единственное число — количество элементов, удовлетворяющих условию.
входные данные
5
1 2 3 4 5
3
выходные данные
2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
GayaneshkaBrainly
18.05.2021 19:50

int main()

{

size_t n;

std::cin >> n;

std::ostringstream out;

for (size_t i = 0; i < n; ++i)

{

static short a;

std::cin >> a;

if (a <= 0) out << (i + 1) << ' ';

}

std::cout<<out.str();

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота