Алекс23102027
29.11.2020 03:25

Составить программу на Паскале. Определить, сколько раз в данном тексте встречается буква «ж». Текст из 5 слов задать самостоятельно. (В ответе представить код программы и результаты работы в виде скриншота окна программы. Программная реализация обязательна.)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MrsKamYl
29.09.2020 16:16
Var St: string;
 z:string[10];
 x:string[2];
i,j,k,m: integer;           //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0;                       //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
 begin;
  for m:=1 to 10 do
   if St[j]=z[m] then inc(k);
 end;
if k=0 then
begin;
 writeln('в тексте нет цифр');
 exit;
end;                              //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.
0,0(0 оценок)
Ответ:
krasovskyko201
11.06.2022 12:26

Основными этапами становления и развития вычислительной техники являются:

1. Ручной - с 50-го тысячелетия до н. э .;

2. Механический - с середины XVII века;

3. Электромеханический - с девяностых годов XIX века;

4. Электронный - с сороковых годов XX века.

1. Ручной период автоматизации вычислений начался на заре человеческой цивилизации. Он базировался на использовании пальцев рук и ног. Счет с группировки и перекладывания предметов явился предшественником счета на абаке - наиболее развитом счетном приборе древности. Аналогом абака на Руси счетов, дошедших до наших дней. Использование абака предполагает выполнение вычислений по разрядам, то есть наличие некоторой позиционной системы счисления. Вычисления на них проводились путем перемещения счетных костей и камешков (Кальк) в полосковых углублениях досок из бронзы, камня, слоновой кости, цветного стекла. В своей примитивной форме абак был дощечкой (позже он принял вид доски, разделенной на колонки перегородками). На ней проводились линии, разделявшие ее на колонки, а камешки раскладывались в эти колонки по тому же позиционным принципом, по которому кладется число на наши счеты. Это нам известно от ряда греческих авторов.

Первым устройством для выполнения умножения был набор деревянных брусков, известных как палочки Непера. Они были изобретены шотландцем Джоном Непером (1550-1617рр.). На таком наборе из деревянных брусков была размещена таблица умножения. Кроме того, Джон Непер в начале XVII века ввел логарифмы, что сделало революционное воздействие на счет. Изобретенная им логарифмическая линейка - это счетный инструмент для упрощения вычислений, с которого операции над числами заменяются операциями над логарифмами этих чисел. Конструкция линейки сохранилась в основном до наших дней. Вычисления с логарифмической линейки проводятся просто, быстро, но приблизительно. И, следовательно, она не годится для точных, например финансовых расчетов. Она, несомненно, является венцом вычислительных инструментов ручного периода автоматизации.

2. Развитие механики в XVII веке стал предпосылкой создания вычислительных устройств и приборов, использующих механический вычислений.

Эскиз механического тринадцятиразрядного устройства заключает с десятью колесами был разработан еще Леонардо да Винчи (1452- 1519рр). По этим чертежам в наши дни фирма IBM в целях рекламы построила работо машину. Первая механическая счетная машина была изготовлена ​​в 1623 г.. Профессором математики Вильгельмом Шиккардом (1592-1636рр.). В ней были механизированы операции сложения и вычитания, а умножение и деление выполнялось с элементами механизации. Но машина Шиккарда вскоре сгорела во время пожара. Поэтому биография механических вычислительных устройств ведется от машины, заключает, изготовленной в 1642 Блез Паскаль (1623-1662), в дальнейшем великим математиком и физиком.

3. Электромеханический этап развития вычислительной техники является наименее продолжительным и охватывает около 60 лет - от первого табулятора Г.Холлерита к первой ЭВМ "ENIAC".

В конце XIX в. были созданы сложные механические устройства. Важнейшим из них был устройство, разработанное американцем Германом Холлеритом. Исключительность его заключалась в том, что в нем впервые была употреблена идея перфокарт и расчеты велись с электрического тока. Это сочетание делало машину настолько работо что она получила широкое применение в свое время. Например, при перечислении населения в США, проведенного в 1890, Холлерит, с своих машин смог выполнить за три года то, что вручную делалось бы в течении семи лет, причем гораздо большим числом людей.

Начало - тридцатые годы XX века - разработка рахунковоаналитичних комплексов, состоящих из четырех основных устройств: перфоратора, контрольника, сортировщика и табулятора. На базе таких комплексов создаются вычислительные центры. В это же время развиваются аналоговые машины.

4. Электронный этап, начало которого связывают с созданием в США в конце 1945 электронной вычислительной машины ENIAC американским инженером-электронщиком Дж. П. Эккерт и физиком Дж.У. Моучли.

В истории развития ЭВТ принято выделять несколько поколений, каждое из которых имеет свои отличительные признаки и уникальные характеристики. Главное отличие машин разных поколений состоит в элементной базе, логической архитектуре и программном обеспечении, кроме того, они различаются по быстродействию, оперативной памяти ввода и вывода информации.

Персональный Компьютер, компьютер, специально созданный для работы в однопользовательском режиме. Появление персонального компьютера напрямую связана с рождением микрокомпьютера.

ПК - настольный или портативный компьютер, который использует микропроцессор как единый центральный процессор, выполняющий все логические и арифметические операции. Эти компьютеры относят к вычислительным машинам четвертого и пятого поколения.

Объяснение:все

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота