ququqhbqha
19.12.2021 00:58

Информатика!Написать программу в Паскале! Номер 4.

Важно! Для решения задач использовать цикл с постусловием! ​


Информатика!Написать программу в Паскале! Номер 4.Важно! Для решения задач использовать цикл с посту

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
taniaselikova
17.04.2021 17:57
Const
  MAX_SIZE = 10;
 
var
  a: array[1..MAX_SIZE] of integer;
  i, size: integer;
 
procedure delete_odd_elements();
var i, j: integer;
begin
  i := 1;
  repeat
    if odd(a[i]) then
    begin
      dec(size);
      for j := i to size do
        a[j] := a[j + 1]
    end
    else inc(i);
  until i > size;
end;
 
begin
  writeln('Исходный массив: ');
  size := MAX_SIZE;
  for i := 1 to size do
  begin
    a[i] := random(100);
    write(a[i] : 3);
  end;
  delete_odd_elements;
  writeln;
  writeln('Полученный массив: ');
  for i := 1 to size do
    write(a[i] : 3);
end.
0,0(0 оценок)
Ответ:
haritonukaleksa
10.10.2020 11:49
Каждая буква в алфавите кодируется определенным количеством бит, чем больше букв, тем больше бит требуется для кодирования. Нам дано, что каждое слово состоит из 5 букв и при этом 1024мя словами исчерпывается словарный запас. Значит если в алфавите Х букв, то на первом месте слове может быть Х вариантов, на втором столько же и так далее. Итого комбинаций Х в степени 5. 
Значит Х в степени 5 = 1024.
Отсюда Х=4.
4 буквы в алфавите. 
Закодировать 4 буквы - 4 варианта можно 2мя битами. 2 в степени 2 =4.
Значит одна буква несет 2 бита информации.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота