liona676
16.04.2022 20:25

Программе <:=>> обозначает оператор присваивания, знаки «+», «-», «*» И <</>> - соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок действий соответствует правилам арифметики. А) Б)

Определите значение переменной а после выполнения алгоритма:

a := 4

b:=9

b:= 6*6 - а

a:=b/5*3-a

В ответе укажите одно целое число значение переменной а

Определите значение переменной ь после

выполнения алгоритма:

a:= 4 b := 15

a := b-a*3

b := 24/a*4

В ответе укажите одно целое число значение переменной ь.

6. Запишите значение переменной s, полученное в результате работы следующей

программы.

А)

var s,k: integer;

begin

s := 0;

for k := 3 to 7 do s:= s + 6;

writeln(s);

end.

var s,k: integer;

begin

s:= 8;

for k := 3 to 8 do

s:= s + 8;

writeln(s);

end.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
НикитаЗеленюк
31.12.2020 12:08

#include <iostream>

#include <cmath>

using namespace std;

signed main() {

   int n;

   cin >> n;

   double a[n];

   for(int i = 0; i < n; i++)

       cin >> a[i];

   double mx = -10000000000000;

   for(int i = n/2; i < n; i++)

       mx = max(mx,a[i]);

   for(int i = 0; i < n-1; i++)

       for(int j = 0; j < n - i - 1; j++)

           if(a[j] > a[j+1])

           {

               double temp = a[j];

               a[j] = a[j+1];

               a[j+1] = temp;

           }

   cout << "maximal element of the second half: " << mx <<"\n";

   cout << "array after sorting: " << "\n";

   for(auto i: a)

       cout << i << " ";

}

0,0(0 оценок)
Ответ:
Ewa11
31.12.2020 12:08

#include <iostream>

#include <cmath>

using namespace std;

signed main() {

   int n;

   cin >> n;

   double a[n];

   for(int i = 0; i < n; i++)

       cin >> a[i];

   double mx = -10000000000000;

   for(int i = n/2; i < n; i++)

       mx = max(mx,a[i]);

   for(int i = 0; i < n-1; i++)

       for(int j = 0; j < n - i - 1; j++)

           if(a[j] > a[j+1])

           {

               double temp = a[j];

               a[j] = a[j+1];

               a[j+1] = temp;

           }

   cout << "maximal element of the second half: " << mx <<"\n";

   cout << "array after sorting: " << "\n";

   for(auto i: a)

       cout << i << " ";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота