папа11111111111111
15.09.2020 05:00

нужно составить программу для вычисления гипотенузы прямоугольного треугольника, если катеты вводятся с клавиатуры в тетраде

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lenahalezina
02.11.2021 10:51
 екстовые редакторы — это программы для создания, редактирования, форматирования, сохранения и печати документов. Современный документ может содержать, кроме текста, и другие объекты (таблицы, диаграммы, рисунки и т. д.).
    
     Более совершенные текстовые редакторы, имеющие целый спектр возможностей по созданию документов (например, поиск и замена символов, средства проверки орфографии, вставка таблиц и др.), называют иногда текстовыми процессорами. Примером такой программы является Word из офисного пакета Microsoft Office.
    
     Мощные программы обработки текста — настоль ные издательские системы — предназначены для подготовки документов к публикации. Пример подобной системы — Adobe PageMaker.
    
     Редактирование — преобразование, обеспечивающее добавление, удаление, перемещение или исправление содержания документа. Редактирование документа обычно производится путем добавления, удаления или перемещения символов или фрагментов текста.
    
     Объектно-ориентированный подход дает возможность реализовать механизм встраивания и внедрения объектов (OLE — Object Linking Embedding). Этот механизм позволяет копировать и вставлять объекты из одного приложения в другое. Например, работая с документом в текстовом редакторе Word, в него можно встроить изображения, анимацию, звук и даже видеофрагменты и таким образом из обычного текстового документа получить мультимедиа-документ.
    
     Форматирование — преобразование, изменяющее форму представления документа. В начале работы над документом целесообразно задать параметры страницы: ее формат (размер), ориентацию, размер полей и др.
    
     Форматирование абзаца. Абзац является одним из основных объектов текстового документа. В компьютерных документах абзацем считается любой текст, заканчивающийся управляющим символом (маркером) конца абзаца. Ввод конца абзаца обеспечивается нажатием клавиши {Enter} и отображается символом Ц.
    
     В процессе форматирования абзаца задаются параметры его выравнивания (выравнивание отражает расположение текста относительно границ полей страницы), отступы (абзац целиком может иметь отступы слева и справа) и интервалы (расстояние между строк абзаца), отступ красной строки и др.
    
     Форматирование символов. Символы — это буквы, цифры, пробелы, знаки пунктуации, специальные символы, такие как @, *, &. Символы можно форматировать (изменять их вид), задавая шрифт, размер и начертание.
    
     Шрифт — полный набор символов определенного начертания, включая прописные и строчные буквы, знаки препинания, специальные символы, цифры и знаки арифметических действий. Для каждого исторического периода и разных стран характерен шрифт определенного рисунка. Каждый шрифт имеет свое название, например Times New Roman, Anal, Courier и др.
    
     По представления в компьютере различаются шрифты растровые и векторные. Для представления растровых шрифтов служат методы растровой графики, символы шрифта — это группы пикселей. Растровые шрифты допускают масштабирование только с определенными коэффициентами.
    
     В векторных шрифтах символы описываются математическими формулами и возможно произвольное их масштабирование. Среди векторных шрифтов наибольшее распространение получили шрифты типа True Type.
    
     Размер шрифта. Единицей измерения размера шрифта является пункт (1 пт = 0,376 мм). В текстовом редакторе Word по умолчанию используется шрифт Times New Roman размером 12 пт. Ниже приведены примеры представления текста с шрифта различного размера:
    
     Шрифт размером 14 пт.
    
     Шрифт размером 10 пт.
    
     Шрифт размером 6 пт
    
     Начертание. Кроме нормального (обычного) начертания символов обычно применяют полужирное, курсивное и полужирное курсивное.
    
     Формат файла определяет хранения текста в файле. Простейший формат текстового файла (ТХТ) содержит только символы (числовые коды символов), другие же форматы (DOC, RTF) содержат дополнительные управляющие числовые коды, которые обеспечивают форматирование текста.
0,0(0 оценок)
Ответ:
Stevejobs1111
19.10.2020 23:35
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016 - №1
begin
  var a,b,c:integer;
  Write('Введите три натуральных числа: '); Read(a,b,c);
  var s:=a+b+c;
  var k:=Trunc(sqrt(s));
  if k*k=s then Writeln('Сумма чисел - квадрат ',k)
  else Writeln('Сумма чисел не является квадратом целого')
end.

Тестовое решение
Введите три натуральных числа: 13 4 8
Сумма чисел - квадрат 5

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016 - №2
begin
  var a,b,c:integer;
  Write('Введите три натуральных числа: '); Read(a,b,c);
  var s:=power(a*b*c,1/3);
  if s=int(s) then Writeln('Среднее геометрическое - целое число')
  else Writeln('Среднее геометрическое - нецелое число')
end.

Тестовое решение
Введите три натуральных числа: 16 8 15
Среднее геометрическое - нецелое число
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота