Xzxzxzxzxzzxzxz
03.12.2020 15:40

Написать программу для решения задачи на Паскале. Дана строка, содержащая текст на русском языке: «Успех лидера вынашивается на плечах бегущих по пятам». В тексте необходимо заменить все символы «а» на «А». В отчет включить программный код на Паскале и результат работы программы в виде скриншота.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sasha808621
27.05.2021 02:28

1) Считываем n и просто в цикле по k от 1 до n прибавляем к текущей сумме новое слагаемое k²:

Код (Python 3):

n = int(input())

s = 0

for k in range(1, n + 1):

   s += k ** 2

print(s)

Пример ввода:

3

Пример вывода:

14

2) Аналогично, только считаем произведение, а не сумму.

Код (Python 3):

n = int(input())

p = 1

for k in range(1, n + 1):

   p *= k

print(p)

Пример ввода:

3

Пример вывода:

6

3) Тут соединяем вместе вычисление n! и суммирование.

Код (Python 3):

n = int(input())

p = 1

s = 0

for k in range(1, n + 1):

   p *= k

   s += p

print(s)

Пример ввода:

3

Пример вывода:

9

0,0(0 оценок)
Ответ:
Relig1d
31.12.2021 01:16
В двоичной системе: 1243(10)=2^10+2^7+2^6+2^4+2^3+2^1+1 = 1024+128+64+16+8+2+1 = 1243(10) =10011011011(2)
В восьмиричной системе:  разбиваете двоичное представление на группы по 3 бита справа налево
011  = 3
011  = 3
011  = 3
10   = 2
Тогда в восьмиричной системе: 2333(8) = 2*8^3+3*8^2+3*8^1+3 = 1024+192+24+3=1243(10)
В шестнадцатиричной системе:  разбиваете двоичное представление на группы по 4 бита справа налево
1011 = B = 11(10)
1101 = D(16) = 13(10)
100  = 4
Тогда в шестнадцатиричной системе
4DB(16) = 4*16^2+13*16^1+11 =1024+208+11=1243(10)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота