KoreanSun1109
12.01.2023 05:33

Составить программу, вычисляющую сумму 1^1+2^2+3^3+...+n^n, паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
staennayanina
17.04.2023 23:08

1. Табличний процесор — категорія програмного забезпечення, призначеного для роботи з електронними таблицями. Спочатку табличні редактори дозволяли обробляти виключно двомірні таблиці, насамперед з числовими даними, але потім з'явилися продукти, що володіли крім цього можливістю включати текстові, графічні та інші мультимедійні елементи. Інструментарій електронних таблиць включає потужні математичні функції, що дозволяють вести складні статистичні, фінансові та інші розрахунки.

2. Комп'ютерна програма, що дозволяє проводити обчислення з даними, представленими у вигляді двовимірних масивів, що імітують паперові таблиці. Деякі програми організовують дані в "листи", пропонуючи, таким чином, третій вимір. Електронні таблиці являють собою зручний інструмент для автоматизації обчислень.

3. Швидкість обробки, відповідно і обсяги обробки, обробка на вимогу в мінімальний час, що дозволяє використовувати результати в подальших операціях, точність розрахунків.

4. бухгалтерія, документообіг.

5-6. трохи некоректне питання. Excel дозволяє вводити в комірки три типи даних: числа, текст, формули. Текст може використовуватися для заголовків таблиць, пояснення або позначок на робочому аркуші. Якщо Excel не розпізнає тип даних як число або формулу, то дані сприймаються як текст.

Числа використовуються для подання цифрової інформації і можуть бути введені в різних форматах: загалом, грошовому, фінансовому, відсоток і т. д. Дата і час можуть також розглядатися як числа.

Формули, введені в комірку, виробляють обчислення, керують роботою бази даних, перевіряють властивості і значення комірок і використовуються для завдання зв'язку між осередками і масивами за до адресних посилань.

Будь-яка формула починається зі знака (=). Якщо в комірку введена формула, то за замовчуванням комірка буде показувати результат розрахунку.

7. -

8. Файл в екселі називають таблицею.  Адреса комірки складається з номера рядка та номера стовпця. (стовпці нумеруються як буквами, так і цифрами).

9. Діапазон осередків-це сусідні осередки, що утворюють прямокутник. Діапазон комірок може складатися з комірок одного стовпця або рядка або з комбінації комірок, розташованих в різних стовпцях і рядках. Основна умова, якій він повинен при цьому задовольняти-осередки обов'язково утворюють прямокутник.

10. На картинке


1. що таке табличний процесор? які можливості він має? 2. що таке електронна таблиця? і з чого вона
1. що таке табличний процесор? які можливості він має? 2. що таке електронна таблиця? і з чого вона
0,0(0 оценок)
Ответ:
mashasandalkina
27.04.2023 22:23

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

double a[50], s = 0, count = 0;

srand(time(NULL));

for (int i = 0; i < 50; i++)

{

 a[i] = -30 + rand() % 41;

               if(a[i]>0)

 {

                      s += a[i];

        count++;

               }

}

cout << s / count << endl;

system("pause");

return 0;

}



Выражение rand() % 41 рандомно принимает любое возможное значение остатка при делении на 41 ( от нуля до 40-а), следовательно -30+ rand()%41 рандомно принимает значение от -30-и до 10-и. Выбираем 50 таких рандомных чисел и храним их в массиве а, заодно в переменной s очередное число, если оно положительное а в переменной count считаем количество положительных чисел. s/count будет средней арифметической всех положительных чисел промежутка.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота