Misterriko70
12.12.2021 14:09

Напишите программу для вывода изображения и результат программы: 1) Обозначить название окна
2) Установите размер окна (400,300)
3) Очистить экран и установить белый фон
4) Нарисовать синий прямоугольник, начиная с точки (140, 60) , длина и ширина сторон 60 пикселей
5) Нарисовать треугольник
6) Обновить экран и завершить работу​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tolikbn85
02.02.2021 12:51
// PascalABC.NET 3.3, сборка 1633 от 10.02.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var x:=ReadReal('x=');
  var y:=Sqr((1-x*x+5*Sqr(x*x)));
  Writeln('y=',y)
end.

Пример
x= 4.12
y=2029704.2032886

2a.
 
begin
  var x:=ReadReal('x=');
  var t1:=x*x; // x^2
  var t2:=t1*t1; // x^4
  t2:=t2*t2; // x^8
  t1:=t2*t1; // x^10
  Writeln('x^10=',t1)
end.

2b.

begin
  var x:=ReadReal('x=');
  var t:=x*x; // x^2
  t:=t*t; // x^4
  t:=t*t; // x^8
  t:=t*t; // x^16
  t:=t/x; // x^15
  Writeln('x^15=',t)
end.
0,0(0 оценок)
Ответ:
VictorBo
02.02.2021 12:51
Var
  x, a, t, y: real;

begin
  Write('Введите значение аргумента x: ');
  Readln(x);
  Write('Введите значение коэффициента a: ');
  Readln(a);
  {боремся с неположительным значением под знаком корня}
  t := a - cos(x);
  if t < 0 then y := exp(x + 1.8) - exp(1 / 5 * ln(-t))
  else if t = 0 then y := exp(x + 1.8)
  else y := exp(x + 1.8) + exp(1 / 5 * ln(t));
  Writeln('Значение функции равно ', y)
end.

Тестовое решение:

Введите значение аргумента x: -4.2
Введите значение коэффициента a: 1.95
Значение функции равно 1.28604638457326
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота