skabshkqbsianshj
10.11.2022 08:45

Определите значение переменной «а» после выполнения фрагмента программы: 1) а=15
b = 10
if not a>8:
a = 12
2) а = 10
b = 5
if a < 1 or a > b:
a = 5
else:
a = 5​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivanBashak1
12.04.2022 05:18
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
0,0(0 оценок)
Ответ:
228795111
11.01.2021 09:04
Программа поиска элемента в произвольном массиве:
const n=10;
var a:array[1..n+1] of integer;
p,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:4);
 end;
writeln;
write('p = '); readln(p);
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if i<=n
 then writeln('Искомый элемент найден, его номер = ',i)
 else writeln('Искомый элемент не найден');
end.

Пример 1:
Исходный массив:
   7  17  16  13   0   1  19  20  12   5
p = 13
Искомый элемент найден, его номер = 4

Пример 2:
Исходный массив:
  20   4   5  12  14  10  11  16  18  20
p = 15
Искомый элемент не найден
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота