Xafe456
20.07.2022 14:01

4. Написать программу решения данной задачи: даны длины катетов прямоугольного треугольника А и В; длины сторон прямоугольника Си D. Определить чья площадь меньше?
5. Для прохождения во второй тур олимпиады по предмету необходимо набрать F . В первом
туре давались 4 задачи, каждая оценивалась соответственно в ли
ученик во второй тур?​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Макслайв
20.12.2020 13:22
Программа выглядит примерно так

program n_1;  type    nazw = array[0..9] of String[15];  const    ed : nazw = ('ноль','один','два','три','четыре','пять','шесть','семь','восемь','девять');    des: nazw = ('','десять','двадцать','тридцать','сорок','пятьдесят',                       'шестьдесят','семьдесят','восемьдесят','девяносто');    sot: nazw = ('','сто','двести','тристо','четыресто','пятьсот','шестьсот','семьсот','восемьсот','девятьсот');    dd : nazw = ('','одинадцать','двенадцать','тринадцать','четырнадцать','пятнадцать',                       'шестнадцать','семнадцать','восемьнадцать','девятнадцать');  var    s,d,e,x : Integer;    st      : String;  Begin    Write('Введите число [0..1000] :'); Readln(x);   if x=1000 then st:='тысяча' else begin    s:= x div 100; x:=x mod 100; st:=sot[s];    d:= x div 10; e:=x mod 10;    if (d=1) and (e<>0) then st:=st+dd[e]                        else st:=st+des[d]+ed[e];   end;    writeln(st);     End.
0,0(0 оценок)
Ответ:
grinanovatana2
25.10.2022 04:30

//PascalABC.NET v3.3 1633

var arr: array [1..6, 1..6] of integer;

begin

 for var i:=1 to 6 do

   for var j:=1 to 6 do

     arr[i, j]:=random(-49, 50);

 

 writeln('Исходный массив: ');

 for var i:=1 to 6 do

     arr[i].PrintLn(', ');

     

 var num:=0;

 for var i:=1 to 6 do

   if arr[i, 2] < 0 then num += 1;

 writeln('Количество отрицательных элементов второго столбца: '+num);

 

 for var i:=1 to 6 do

   for var j:=1 to 6 do

     if arr[i, j] > 0 then arr[i, j]:=-49;

 writeln('Новый массив: ');

 for var i:=1 to 6 do

     arr[i].PrintLn(', ');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота