Farys
30.09.2022 19:19

С ИНФОРМАТИКОЙ Задание 1
Составить программу на Паскале. Определить, сколько раз в данном тексте встречается буква «ж». Текст из 5 слов задать самостоятельно.

Задание 2
Составить программу на Паскале, которая удалит все буквы «е» из текста, который состоит из 5 слов. Текст нужно придумать самостоятельно.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
veraorfey
12.06.2021 11:39

Pascal

var

 s1:string = 'Дружба от недружбы близко живёт.';

 s2:string = 'Доброе дело два века живёт.';

 i, c :integer;

begin

 c:=0;

 for i:=1 to length(s1) do

   if s1[i]='ж' then

     inc(c);

 writeln(s1, '  В предложении букв "ж"=',c);

 i:=1;

 while i <= length(s2) do

   if s2[i]='е' then

     delete(s2, i, 1)

   else

     inc(i);

 writeln(s2);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота