Добрыйдемон13
13.01.2022 19:28

Напишите программу с циклом фор для вывода на экранах всех чисел кратных 3 в дипазоне [-48;6]​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1234567х91011111223
01.01.2022 14:41

ответ: Значения, на основе которых выполняются вычисления. Аргументы вводят в круглых скобках сразу после имени функции. Аргументами могут быть числа, адреса ячеек, текст, выражения, содержащие другие функции.

Функции, используемые на уроках математики.

СУММ(В2:В5) – вычисление суммы числовых значений диапазона ячеек начиная с В2 до В5.

СУММ(В2:В5;100;К4) – вычисление суммы числовых значений диапазона ячеек В2:В5, числа 100 и значения ячейки К4.

СУММЕСЛИ(В2:В5;”>10”) – вычисление суммы чисел, больших 10, из диапазона ячеек В2:В5.

СРЗНАЧ(В2:В5) – вычисление среднего значения для диапазона ячеек В2:В5.

МАКС(В2:В5) – вычисление максимального значения из диапазона ячеек В2:В5.

МИН(В2:В5) – вычисление минимального значения из диапазона ячеек В2:В5.

СЧЕТ(В2:В5) – подсчёт общего количества чисел из диапазона ячеек В2:В5.

СЧЕТЕСЛИ(В2:В5;”<5”) – вычисление количества чисел меньших 5, из диапазона ячеек В2:В5.

СТЕПЕНЬ(В1;А4) – вычисление значения степени с основанием В1 и показателем степени А4.

КОРЕНЬ(В1) – вычисление значения квадратного корн

0,0(0 оценок)
Ответ:
nezervillager
17.02.2022 21:52

#include <iostream>

#include <cmath>

#include <ctime>

using namespace std;

int main (void)

{

 srand (time (0));

 int Temp = 0;

 int max = 1;

 int maxi = 0;

 int n = 0;

 cout << "Input n = ";

 cin >> n;

 cout << endl;

 int *A = new int[n];

 for (int i = 0; i < n; i++)

   {

     A[i] = -10 + rand () % 30;

     cout << A[i] << "   ";

   }

 for (int i = 0; i < n; i++)

   {

     if (abs (A[i]) > abs (max))

{

  max = A[i];

  maxi = i;

}

   }

 cout << "\nABS(Max) = " << max << "  Number = " << maxi;

 Temp = A[n - 1];

 A[n - 1] = max;

 A[maxi] = Temp;

 cout << endl;

 for (int i = 0; i < n; i++)

   {

     cout << A[i] << "  ";

   }

 delete[]A;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота