kseni23112001
10.03.2021 09:40

Составить программу для
упорядочивания учащихся
класса по росту. Пофамильный
список ввести с
массива констант, рост
каждого учащегося вводится с
клавиатуры по запросу
программы. Выбор сортировки
(пo возрастанию или убыванию) происходит во время выполнения программы.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Babl11
25.09.2021 03:57

доделал. Pascal

Объяснение:

program basket;

uses crt;

var N,i,k:integer;

   rost: array of integer;

   fam, kom: array of string;

BEGIN

Clrscr;

writeln('Введите количество учеников');

readln(N);

setlength(fam, N);

setlength(rost, N);

setlength(kom, N);

writeln('Введите фамилии и рост учеников:');

for i:=0 to N-1 do

begin

write('fam[',i,']= ');

read(fam[i]);

write('rost[',i,']= ');

readln(rost[i]);

end;

k:=0;

for i:=0 to N-1 do

if rost[i]>=170 then begin

kom[k]:=fam[i];

k:=k+1;

end;

if k=0 then

writeln('кандидатов нет')

else

writeln('Список претендентов в сборную школы:');

for i:=0 to k-1 do

writeln(kom[i]);

readln;

end.

0,0(0 оценок)
Ответ:
aleksbotalov33p00u0t
25.09.2021 03:57

Pascal

program basket;

uses crt;

var

 fam, kom : array of string;

 rost : array of double;

 N,i:integer;

BEGIN

 Clrscr;

 writeln('Введите количество учеников');

 readln(N);

 setlength(fam, n);

 setlength(rost, n);

 writeln('Введите фамилию и рост ученика');

 for i:=1 to N do begin

   write('fam[',i,']= ');

   read(fam[i-1]);

   write('rost[',i,']= ');

   readln(rost[i-1]);

 end;

 for i:=1 to N do

   if rost[i-1]>=170 then begin

     setlength(kom, length(kom)+1);

     kom[length(kom)-1]:=fam[i-1];

   end;

 if length(kom)=0 then

   writeln('кандидатов нет')

 else

   writeln('Список претендентов в сборную школы');

 Writeln;

 for i:=1 to length(kom) do

   writeln(kom[i-1]);

 readln

end.


1. Сделайте эту программу работо . program basket; uses crt; var N,i,k:integer; BEGIN Clrscr; writel
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота