TimurA1
26.01.2020 01:04

написать программу на паскале: Опpеделить комбиниpованный тип для пpедставления анкеты студента-пеpвокуpсника, включающей в себя его фамилию (до 12 букв), номеp гpуппы (целое от 80 до 99), оценки по тpем пpедметам (химия, физика, пpогpаммиpование). Написать пpогpамму, котоpая pаспечатывает из этой инфоpмации название пpедмета, котоpый был сдан лучше всего.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
сафаралиев
05.01.2022 05:59
В предыдущем вопросе я написала решение.
program z;
var a,b,c,d,e,x,g,h:integer;
begin
write('Введите пятизначное число');
read(x);
a:= x mod 10;
b:= x mod 100;
b:= b div 10;
c:= x mod 1000;
c:= c div 100;
d:= x mod 10000;
d:= d div 1000;
e:= x mod 100000;
e:= e div 10000;
if a mod 2=0 then h:=a
else g:=a;
if b mod 2=0 then h:=h+b
else g:=g+b;
if c mod 2=0 then h:=h+c
else g:=g+c;
if d mod 2=0 then h:=h+d
else g:=g+d;
if e mod 2=0 then h:=h+e
else g:=g+e;
writeln(' Сумма нечётных цифр равна ', g);
write(' Сумма чётных цифр равна ', h);
end.
0,0(0 оценок)
Ответ:
dssh70
02.09.2021 11:03
var
  s: string;
  i, j, n: integer;
  c: char;
  flag: boolean;

begin
  Write('Введите произвольное число: '); Readln(s);
  flag := false;
  n := length(s);
  i := 1;
  while (i <= n) and (not flag) do
  begin
    c := s[i];
    j := i + 1;
    while (j <= n) and (not flag) do
      if s[j] = c then flag := true else j := j + 1;
    if (not flag) then i := i + 1
  end;
  if flag then Writeln('Символ "', c, '" встречается больше одного раза')
  else Writeln('Все символы уникальны')
end.

Тестовое решение:
Введите произвольное число: -1453.5462
Символ "4" встречается больше одного раза
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота