Напишите программу, которая запрашивает 5 целых чисел, и определяет, сколько среди них нечётных. Числа подаются одной строкой через пробел. Sample Input 1: 8 11 13 7 -23
1. begin var a:=ArrRandom(10,1,50); a.Println; var c:=ReadInteger('c = '); var s:=a.Where(x->x>c); if s.Count>0 then writeln('Среднее арифметическое элементов > ',c,' = ',s.Average) else writeln('В массиве нет искомых элементов'); end.
Пример: 8 2 22 16 24 34 29 16 1 26 c = 50 В массиве нет искомых элементов
2. const n=10; var a:array[1..n] of integer; c,i,s,k:integer; begin Randomize; for i:=1 to n do begin a[i]:=random(51); write(a[i],' '); end; writeln; write('c = '); readln(c); s:=0; k:=0; for i:=1 to n do if a[i]>c then begin s:=s+a[i]; k:=k+1; end; if k>0 then writeln('Среднее арифметическое элементов > ',c,' = ',s/k:5:2) else writeln('В массиве нет искомых элементов'); end.
Var a: array of real; i,n,m,k,p: integer; s: real; begin write('n = '); readln(n); setlength(a,n); s:=1; randomize; writeln('массив:'); for i:=0 to n-1 do begin a[i]:=random(200)/1000; s:=s*a[i]; write(a[i]:5:3,' '); end; writeln; s:=power(s,1/n); p:=0; m:=0; k:=0; writeln('среднее геометрическое: ',s); for i:=0 to n-1 do begin if a[i]<s then inc(m); if a[i]>s then inc(k); if a[i]=s then inc(p); end; writeln('меньше: ',m,' равно: ',p,' больше: ',k); end.