VictorTsoy1962
02.02.2020 11:44

нужно. Написать программу, которая сортирует массив из N элементов по убыванию методом «пузырька» и считает при этом количество произведённых перестановок. Протести-ровать программу на следующих исходных данных:(на языку паскаля) а) 2 5 1 6 4 10 4 2
б) 1 2 5 6 -4 0 11 12
в) 12 10 6 4 2 1 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anastasiyaaldo
21.04.2022 22:17

Program pryam;

Var y1, y2, y3, x1, x2 : real;

Begin

  writeln ('Введите координату (у) верхней точки прямой');

  readln (y1);

  writeln ('Введите координату (у) нижней точки прямой');

  readln (y2);

  writeln ('Введите координату (х) точек-концов прямой');

  readln (x1);

  writeln ('Введите координату (у) точки, принадлежность к прямой которой нужно определить');

  readln (y3);

  writeln ('Введите координату (х) точки, принадлежность к прямой которой нужно определить');

  readln (x2);

if (y3<=y1) and (y3>=y2) and (x2=x1) then writeln (' принадлежит ')

else writeln (' не принадлежит ');

readln;

End.

0,0(0 оценок)
Ответ:
Lori04
14.08.2020 23:31
Информационная деятельность - это совокупность действий, направленных на удовлетворение информационных потребностей граждан, юридических лиц и государства.
В целях удовлетворения этих потребностей органы государственной власти и органы местного и регионального самоуправления создают информационные службы, системы, сети, базы и банки данных.
Порядок их создания, структура, права и обязанности определяются Кабинетом Министров Украины или другими органами государственной власти, а также органами местного и регионального самоуправления.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота