KirikRu
13.11.2021 11:30

Составить программу построения 20 случайных прямоугольников. Pascal ABC​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mynir
14.09.2022 02:49
// меньшее из двух чисел (a,b) уменьшите на 4

Var x,y   : real;
begin
  writeln ('Введите первое число');
  readln (x);
  writeln ('Введите второе число');
  readln (y);
  while x=y do
    begin
      writeln ('Вы ввели равные числа. По условиям задачи числа не должны быть равны. Попробуйте еще раз');
      writeln ('Введите первое число');
      readln (x);
      writeln ('Введите второе число');
      readln (y);
    end;
  if x<y then x:=x-4
           else y:=y-4;
 writeln ('Первое число ',x,' Второе число ',y);       
end.
0,0(0 оценок)
Ответ:
помогите1187
19.09.2020 23:07
// дан массив Q(15) , заполненный числами [0,100].Найдите количество чётных чисел и их сумму
Var Q    : array [1..15] of byte;
    i,n  : byte;
    s    : word;
begin
  randomize;
  for i:=1 to 15 do
    begin
      Q[i]:=random(101); //заполняем массив случайными числами
    end;
  for i:=1 to 15 do
    begin
      if (Q[i]mod 2=0) then //определяем четные чиcла
        begin
          n:=n+1;           //высчитываем их количество
          s:=s+Q[i];        //и сумму
        end;
    end;
writeln ('в данном массиве ',n,' четных чисел. Их сумма равна ',s)
end.

Первый и второй циклы можно объединить (я так делал для наглядности) 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота