annett3453
22.02.2022 09:00

Напишите программу вычисления выражения на C++:
99 – 98 + 97 – 96 + 95 – 94 + ... + 5 – 4 + 3 – 2 + 1

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sashacat555
11.05.2021 08:50

99-98+97+96+95-94+6+5-4+3-2+1

а?

0,0(0 оценок)
Ответ:
anton280605
11.05.2021 08:50

#include <iostream>

using namespace std;

signed main() {

int s = 0;

for (int i = 99; i >= 1; i--) {

 if ((i & 1) == 0)

  s -= i;

 else

  s += i;

}

cout << s;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота