denpop648p08mew
30.05.2023 22:54

1. Составить программу, находящую сумму всех трёхзначных чисел, оканчивающихся на 6.

2. С клавиатуры вводятся 13 целых чисел.Найти произведение нечётных.

Паскалем

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Romanova33
18.11.2022 01:05
  program proga_25_1;
 Var
A: text;     
i,j,n,m : byte;     
 d: string;     
Sim:char;
 Begin             
write('Введите имя текстового файла   ');  {Например: "test" он создастся там где находится сама программа }               
read(d);                                       
 Assign(A,d);               
 rewrite(A);                   
 write('Введите количество строк: N= ');                        
readln(n);                   
 write('Введите количество символов в строке: M= ');                     
  readln(m);                                     
for I:=1 to n do                   
 begin                         
 Sim:=Chr(Ord('1')+I-1);                         
  For J:=1 to m do                             
  write(A,Sim);                               
 writeln(A);                 
  end;                         
  close(A);
end.     
0,0(0 оценок)
Ответ:
Unicorn471
18.11.2022 01:05
Program proga;
Var  
p: text;   
  i, n : byte;     
 s,min,m: string;     
 Begin                         
 write('Введите имя файла   ');  {Например: C:.txt}                         
 read(m);
Assign(p,m);      
  reset(p);
    read(p,s);
 min:=s;   
 n:=100;   
 for i:=1 to n do   
 begin     
readln(p,s);                                      
while not eof(p) do  
 {нахождение минимальной строки}       
   begin         
 readln(p,s);       
   if length(s) <= length(min) then        
  min:=s;         
 end;          
 end;
close(p);   
 write('самая короткая строка: ',min);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота