pipidonkamnevce
19.09.2020 15:26

дан массив d(c,c).Найти среднее арифметическое элементов меньше 20 под побочной диагональю.Составить программу Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Liana250202
17.01.2022 10:06
1.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of integer;

 x,max,min,i: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

max:= a[1];

min:= a[1];

for i:=1 to n do

begin

 if max < a[i]

   then max:= a[i];

 if min > a[i]

   then min:= a[i];

end;

writeln;

write('Массив: ');

for i:=1 to n do

 write(a[i],' ');

writeln;

writeln('Наибольший элемент: ',max);

writeln('Наименьший элемент: ',min);

end.

2.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of real;

 x,i: integer;

 min: real;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

min:= a[1];

for i:=1 to n do

 if min > a[i]

   then min:= a[i];

for i:=1 to n do

 a[i]:= a[i]/min;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

3.                                        

program raf105;

const

 n = 8;

var

 a: array[1..n] of integer;

 x,i,max: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

max:= a[1];

for i:=1 to n do

 if max < a[i]

   then max:= a[i];

for i:=1 to n do

 a[i]:= a[i]+max;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

                                          PascalABC 3.4.2
0,0(0 оценок)
Ответ:
Анютка0055
17.01.2022 10:06

1.

const n=5;

var a:array [1..n] of integer;

i:integer;

begin

write('       Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(21)-10;

write(a[i]:3,' ');

if a[i] mod 2 = 0 then a[i]:=a[i]-3

end;

writeln;

write('Преобразованный массив: ');

for i:=1 to n do write(a[i]:3,' ')

end.

2.

const n=8;

var a:array [1..n] of integer;

i,s:integer;

begin

write('Массив: ');

for i:=1 to n do

begin

a[i]:=random(21)-10;

write(a[i]:3,' ');

s:=s + a[i]

end;

writeln;

write('Сумма всех элементов массива: ',s)

end.

3.

const n=7;

var a:array [1..n] of integer;

i,p:integer;

begin

p:=1;

write('Массив: ');

for i:=1 to n do

begin

a[i]:=random(21)-10;

write(a[i]:3,' ');

if a[i] > 0 then p:=p * a[i]

end;

writeln;

write('Произведение положительных элементов массива: ',p)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота