ryure146
14.09.2021 20:10

Для заданного числа n составьте программу вычисления суммы s=1+1/2+1/3+1/4+…+1/n, где n – натуральное число через repeat,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kennY1771
24.09.2021 21:57

осле того, как текст набран и проверен, желательно придать ему внешний вид, облегчающий восприятие написанного. Для этого различные смысловые части документа принято выделять шрифтами разных гарнитур (например, с засечками и без засечек) или разных начертаний (курсивного, полужирного), отступами, дополнительными межстрочными интервалами (отбивками) и другими

Например, заголовок документа желательно набрать более крупно и разместить его по центру страницы, подписи к рисункам оформить курсивом, а номера страниц разместить в правом нижнем углу каждой страницы.

Присвоение параметров оформления определённым частям документа принято называть форматированием.

Форматирование может быть жёстким или мягким. При жёстком форматировании каждой конкретной части документа — символу, слову, абзацу или странице задаются определённые параметры отображения. При этом форматирование никак не связано с логической структурой документа и объекты, логически относящиеся к одному типу, могут оказаться (и почти всегда оказываются, как показывает практика) оформленными по-разному. Например, одна из подписей к рисункам не будет выделена курсивом, в отличие от остальных.

При мягком форматировании описывается внешний вид не конкретного фрагмента текста, а логической части документа — заголовков, основного текста, сносок, колонтитулов, а для каждой конкретной части документа задаётся только её роль в документе: например, «подпись к рисунку». Описание оформления для определённой логической части документа принято называть стилем.

При использовании стилей необходимо логически разметить документ, т. е. обозначить его структуру. Отмечается, что в документе является заголовком, что основным текстом, а что другими элементами. При этом каждый элемент примет внешний вид в соответствии с тем стилем, который для него определён.

Использование логической разметки документа и мягкого форматирования облегчает работу с большими и сложными по структуре документами и позволяет автоматизировать многие этапы работы с текстом — автоматически создавать оглавления, легко перемещаться по большим документам, быстро изменять оформление и многое другое

0,0(0 оценок)
Ответ:
раф15рус
02.01.2020 11:36
Program n;
var
a, b, i: integer;
begin
b:= 0;
for i:=1 to 4 do
  begin
  readln(a);
  if a > b then
  b:=a;
  end;
writeln('Наибольшее: ' + b);
end.

Как это работает?
Объявляются три целочисленные (interger) переменные:
a - вводимое число
b - самое большое число
i - счётчик цикла
После запуска программы переменной b присваивается значение 0 (чтобы было с чем сравнивать при первом значении)
Запускается цикл for с счётчиком i
Каждый раз цикл просит ввести пользователя число (а)
Дальше проверяется условие, если введённое число a больше числа, которое записано как самое большое (if a>b)
Если ведённое число больше, чем самое большое, то переменной b присваивается значение a
И так пока цикл не закончится
Затем выводится переменная b, в которой хранится самое большое из введённых чисел.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота