selipups96
27.09.2022 01:01

Создать программу, которая будет вычислять натуральные степени заданного натурального числа от первого до заданного степени. Входные данные: число, самый степень. Выходные данные: в столбик все степени от первого до заданного. Через АЛГО.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DevochkaYmnichka
20.04.2021 07:02
Тема:Язык программирования,,QBasic"
1.Графика языка(графические операторы).
А)Слово которое соответствует блоку ,,начало"или,,пуск".
REM(ремарка)-это слово означает что будет создана программа с какимто именем,или это слово используют для-коментария в программе.
Например:REM,,RRIMER".Имя программы может быть условным.
Б)слово которое очищает экран CLS используют в начале программы или по необходимости.
В)END-это окончание программы
Г)SCREEN-N-номер экрана
чертиж прямую линию 4см,потом линию с боку правого или левого 2см и так должен получиться прямоугольник сверху это будет x а с левого боку Y
0,0(0 оценок)
Ответ:
temaganenko
23.04.2022 21:34
#include<iostream>
#include<Windows.h>
#include<locale>

int main()
{
  setlocale(LC_ALL, "Russian");

  int a, b;
  int  n;

  std::cout << "Введите числитель: ";
  std::cin >> a;

  std::cout << "Введите знаменатель:";
  std::cin >> b;

  n = a < b ? a:b;

  for(int i=1; i<=n; i++)
    if(!(a%i) && !(b%i)) 
    { 
      a/=i; 
      b/=i; 
    }

  std::cout << " " << a << " \n" << "---";
  if(b == 1) std::cout << " = " << a;
  std::cout << "\n " << b << " \n";
 
  system("pause");

  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота