mariii222
19.10.2021 08:23

Напишите программу для андроида на языке Java которая будет генерировать случайное квадратное уравнение а после выводить на экран для того чтобы человек мог вписать ответ и программа сказала бы правильно решено уравнение или нет, в случае неправильно решенного уравнения программа генерировала новое уравнение до того момента пока человек не решит его правильно после этого программа завершалась.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elsem78
25.12.2022 11:31

В объяснении

Объяснение:

1 Вариант

1. 1)ppt

2. 1) my.doc, bell.txt, song.docx;

3. 3)мышь

4. 1) красного, синего, зеленого

5.Объем сообщения определяется по формуле:

V=l*r,

где l-длина сообщения, r-разрешение.

l=50, т.к.всего в предложении 50 символов (пробелы и знаки препинания являются символами).

r=1 байт=8 бит.

Объем сообщения равен:

V=50*8=400 бит.

6. не понятно, что делать, задания не видно как-то

7.InternetExplorer= 73 110 116 101 114 110 101 116 69 120 112 108 111 114 101 114

8. Нет рисунка  собственно

9.  64 бита < 16 байт

10 Кбайт < 10600 байт

10 байт = 80 бит

10. Нет схемы

0,0(0 оценок)
Ответ:
nazarshariu77
12.04.2020 12:35

должно по идее получиться "нет худо без добра.", но у меня получилось

"нет худо бrз одра." может ты в условии что-то напутала? вот программа которая переводит

 

function Pow(a, x:integer):integer;
var
  rez, i:integer;
begin
  rez := 1;
  for i := 1 to x do
    rez := rez * a;
  Pow := rez;
end;

function BinToDec(a:string):integer;
var
i ,r:integer;
begin
  r := 0;
  for i := length(a) downto 1 do
    r := r + StrToInt(a[i]) * Pow(2, length(a) - i);

  BinToDec := r;
end;

var
  s:array[1..100] of string;
  i:integer;
begin
  s[1] := '11001101';
  s[2] := '11100101';
  s[3] := '11110010';
  s[4] := '00100000';
  s[5] := '11110101';
  s[6] := '11110011';
  s[7] := '11100100';
  s[8] := '11100000';
  s[9] := '00100000';
  s[10] := '11100001';
  s[11] := '1110010';
  s[12] := '11100111';
  s[13] := '00100000';
  s[14] := '11101110';
  s[15] := '11100001';
  s[16] := '11110000';
  s[17] := '11100000';
  s[18] := '00101110';
  for i := 1 to 18 do
    write(chr(BinToDec(s[i])));
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота