Войти
Регистрация
Спроси ai-bota
Гульжа1234
25.03.2021 05:11
TKINTER PYTHON: задача 2: создать узор из горизонтальных линий
задача 3: создать узор в клетку
задача 4: создать узор на половине полотна (половину горизонтальных, половину вертикальных
P.s надеюсь найдется тот человек который ,
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
lidok575
29.07.2022 03:14
Пользователь-человек в твою программу вводит два числа а программа ему пишет, какое из них больше написать программу в паскале ....
ЖаннаЛьюес
30.12.2022 04:47
Выполни алгоритм для каждой птицы,показанной на рисунке. запиши результат в рабочей тетради....
Альбина1597
23.04.2023 01:40
Может ли звуковая карта передавать звуковую информацию или она служит только для ввода звуковой информации?...
Pilulkin112
23.04.2023 01:40
Заполните массив по следующему принципу: 1020304 0506070 809010011 0120130140 побыстрее...
Sashademin06
19.05.2023 10:05
Нужна программа для расчёта средней загруженности членов бригады при известном общем объёме работ (в часах) и количестве рабочих....
OlgaBliznyak
10.05.2022 10:10
Нарисовать диаграмму Венна для утверждения: Киты являются млекопитающими. Дельфины являются млекопитающими Млекопитающие являются животными...
RihDest
29.08.2020 06:50
Скорость передачи информации 0,25 кбит/сек. за какое время в минутах можно передать 128 страниц, если на каждой странице 12 строки по 32символа в строке. один символ занимает...
shark741
29.08.2020 06:50
Определите информационный объем изображения при растровом кодировании черно белого рисунка содержащего 120 пикселей...
zhaniyaadilshi
29.08.2020 06:50
Расположить в порядке убывания : 25 бит, 20бит, 3 байта, 101 байт...
Vanek255
29.08.2020 06:50
Как вычислить примеры: а) 10101001 2 + 32330 4 (ответ записать с основанием 4) б) 2121321 3 * аес 16 (ответ записать в системе счисления с основанием 11)...
Ответ:
margusqw
03.02.2021 07:05
Судя по всему, здесь в цикле складываются квадраты всех нечетных чисел от m до n включительно.
m & 1 - это битовая конъюнкция. Результатом будет 1, если m нечетное, и 0, если m - четное (то есть, содержит или не содержит соответствующий разряд)
Выражение вида T ? X : Y, где T - логическое высказывание, принимает значение X, если T истинно, и Y, если T ложно.
Соответственно, i = (m & 1) == 1 ? m : m + 1 означает, что
если m нечетное, то i = m
если четное, i = m+1 (то есть, первое нечетное число после m)
i += 2 означает, что цикл идет с шагом, соответственно, рассматриваются только нечетные числа.
0,0
(0 оценок)
Ответ:
ilyamilovanov1
23.04.2021 01:58
Class ArrayEven{
public static void main(String args[]){
java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
while((eArray[eArray.length-1] = in.nextLong())!=-1){
long nArray[] = new long[eArray.length+1];
for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
eArray = nArray;
} eArrayCell:
for(int cCell = 0; cCell<eArray.length-1; cCell++){
if(eArray[cCell]%2==1)continue;
else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
if(eArray[eCell]%2==1){
eArray[eArray.length-1]=eArray[cCell];
eArray[cCell]=eArray[eCell];
eArray[eCell]=eArray[eArray.length-1];
continue eArrayCell;
}
break;
}
for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
}
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота