letych
24.11.2022 20:32

Написать программу, отвечающую можно ли переходить дорогу и выслать программу учителю. Пример выполнения программы приведен ниже:


Написать программу, отвечающую можно ли переходить дорогу и выслать программу учителю. Пример выполн
Написать программу, отвечающую можно ли переходить дорогу и выслать программу учителю. Пример выполн

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nikita20053103
21.10.2022 08:59
Программа на языке PascalABC

program raf105;

var abc,ab,bc:integer;

begin

write('Введите трёхзначное число: ');

readln(abc);

ab:= abc mod 100;

bc:= abc div 10;

if ab = bc

 then writeln('Число состоит из одинаковых цифр')

 else writeln('Число не состоит из одинаковых цифр');

end.

Объяснение

Для выполнения задачи достаточно найти первые 2 цифры и последние 2 цифры если они равны, то число состоит из одинаковых цифр

abc mod 100 Убирает все сотни из числа.

Например было число 123, стало 23.

482 стало 82

abc div 10 Считает сколько в числе целых десяток, но не считает остаток.

Например было число 123, стало 12

482 стало 48

Сравнивание 2 первых и 2 последних цифр

253      25 и 53 не равны, значит число не состоит из одинаковых цифр

121       12 и  21 не равны, значит число не состоит из одинаковых цифр

111        11 и 11  равны, значит число состоит из одинаковых цифр

0,0(0 оценок)
Ответ:
AA7777AA
11.02.2021 09:41

1.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<=-4 then  

   y:=x*x*x-2;  

 if 6<=x then  

   y:=40-x;  

 if (-4<x) and (x<6) then  

   y:=x*x;  

 writeln('y ',y:1:3)  

end.

3.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<1 then  

   y:=2*x-17;  

 if (1<=x) and (x<=5) then  

   y:=exp(ln(x)*7);  

 if 5<x then  

   y:=x*ln(x);  

 writeln('y ',y:1:3)  

end.

exp(ln(x)*n)

,где n - степень , x - выражение.

(используется во втором упражнение которое я решил, согласитесь лучше будет выглядеть чём х*х*х*х*х*х*х)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота